Server to Cloud Migration Process is Failing
Incident Report for ProjectBalm
Postmortem

We determined that the problem stemmed from our use of a Cloud API endpoint that produces a long-running task: a bulk update of issue properties. A logic error in our handling of such long-running tasks caused our HTTP request pipeline to stall. We corrected the logic error and asked customers to restart their migrations.

We conducted a Post Implementation Review and found the response and communications were appropriate. We have updated the process to ensure this portmortem is created in a timely manner.

Posted Mar 05, 2024 - 14:14 AEDT

Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 02:39 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2024 - 23:29 AEDT
Update
We are continuing to investigate this issue.
Posted Feb 27, 2024 - 23:10 AEDT
Investigating
The Risk Register server to cloud migration process is currently failing.
Posted Feb 27, 2024 - 23:10 AEDT
This incident affected: Risk Register for Jira Cloud.