Intermittent Bug Impacts Migrations
Incident Report for ProjectBalm
Resolved
This incident has been resolved.
Posted Apr 28, 2023 - 18:24 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 17:05 AEDT
Update
We are continuing to work on a fix for this issue. Since the changes have turned out to be more extensive than first anticipated, we expect the solution to be released early next week.
Posted Mar 09, 2023 - 15:49 AEDT
Update
A fix for this issue is under construction. At this moment, we are confident that it will be solved before the end of this week.
Posted Mar 06, 2023 - 17:12 AEDT
Identified
We want to update you on the intermittent issue we have been experiencing with our Risk Register migrations. We have identified the cause of the problem to be related to Jira's rate limiting algorithm. We have been working hard to find a solution and are pleased to report that we have made progress. Our team is currently implementing a strategy that will allow our app to gradually reduce the number of requests made during the migration process, ensuring that all migration workloads are processed successfully.

This issue is our top priority, and we are doing everything we can to resolve it as quickly as possible. We will continue to keep you informed of our progress and provide updates on the estimated completion time as soon as we have more information.

We apologize for any inconvenience this has caused and appreciate your patience as we work to fix the issue. Thank you for your understanding.
Posted Mar 05, 2023 - 22:47 AEDT
Investigating
The issue manifests as an intermittent failure of the migration process, resulting in a partial migration with the process never marked as complete.

It has been observed that this bug occurs sporadically and is not limited to a specific set of conditions. Our team of technical experts is actively investigating the issue and working to identify a permanent solution.

We apologize for any inconvenience caused by this issue and assure you that we are fully committed to resolving this matter as quickly as possible to minimize the impact on our users.
Posted Mar 05, 2023 - 22:45 AEDT
This incident affected: Risk Register for Jira Cloud and Risk Register for Jira Server and Jira Data Center.